CD Right!

CD creation software
just Right for you

USER’S GUIDE




WARNING

This software is designed to assist you in reproducing materials in which you
own the copyright or have obtained permission to copy from the copyright
owner. Unless you own the copyright or have permission to copy from the
copyright owner, you may be violating copyright law and be subject to pay-
ment of damages and other remedies. If you are uncertain about your rights,
you should contact your legal advisor.

CUSTOMER SUPPORT

Sony is serious about customer support. If you encounter difficulty using
this product, you can get technical support by the following means:

Sony Computer Peripherals Technical Support: (800} 597-5649
24 hours per day, 365 days per year

Sony FastFacts™ FAX on Demand Service: (800) 883-7669
24 hours per day, 365 days per year

Sony Computer Peripherals BBS: (408) 955-5107
24 hours per day, 365 days per year

Sony Computer Peripherals Technical Support Web Site:
http://www.ita.sel.sony.com/support
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CD Right! Overview

CD RECORDING FOR THE REST OF US

Congratulations on acquiring Sony CD Right!, the first CD-R software which
truly enables “CD recording for the rest of us.”

Derived from years of experience in the design of CD mastering software, CD
Right! is a Win32 (Microsoft Windows 95* and Windows NT™ ) software
application for CD-Recordable (CD-R) drives. It represents the latest advance-
ments in the technology in terms of ease-of-use combined with outstanding
functionality.

CD Right’s “2 Click-Cut” interface has been designed using the latest
advances in Windows 95 shell integration techniques while maintaining a stan-
dard interface look and feel. The result is a incredibly easy to use CD creation
tool. If you know Microsoft Windows 95, you’ll quickly know CD Right!

Don’t be misled, however, by its ease-of-use. At the heart of this world-class
product is an engine that is sufficiently powerful for the most demanding of
users.

Please take a moment to read this manual in order that you familiarize your-
self with the key aspects of CD Right! We trust that you will agree that
“Finally, someone got it right”!
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WHAT YOU CAN DO WITH CD Ricur!

CD Right! is a “general purpose™ CD creation application which allows you
to perform both basic and complex recording operations with CD recorder
(CD-R) drives. Specifically, CD Right! empowers you to:

* Duplicate your own recordable discs or make a backup copy of an exist-
ing silver Compact Disc, reading from one CD-ROM or CD recorder drive,
and recording directly to another CD recorder without making any tempo-
rary file on your hard disk.

* Copy Compact Discs using the same CD recorder for reading and writing
by making a temporary copy of the disc on hard disk.

* Record data CD-ROM s in the universally compatible 1SO-9660 format.
This means dragging your folders and files into the CD Right! window and
then beginning the recording process. This can be done, using completely
blank or partially used recordable discs thanks to the multisession capability
of CD Right! Multisession recording can be accomplished by making a new
“volume” in the blank space, i.e. ignoring what was already on the disc, or
by “loading from the previous session”, i.e. adding only new or updated files
to save space.



¢ Create audio compilations from songs present on your hard disk as Wave
files or from other audio discs inserted in the CD-ROM of your computer.
This audio compilation is done all at once. You start with a blank CD-R disc
and record the entire set of songs. You should regard this as a complete
“opera” made in a single step. If you record directly from other audio
Compact Discs, these Compact Discs must be online. CD-ROM disc chang-
ers are great to make complex compilations from many source discs.
Otherwise you can extract the songs from your hard drive.

Use your CD recorder like a cassette recorder by using the

CD Ditto DJ function. Starting with a blank CD-R disc, you can record
Wave files or sound tracks from other audio Compact Discs. You can even
record directly from your sound board more than one hour of radio music or
any music coming from any sound device attached to the sound board’s line-
in jack. Such a disc can be started today and continued tomorrow by adding
more songs (tracks). Before a disc is finished, it can be played in the CD
Recorder using CD Ditto DJ. When the disc is complete and “finished”, it
can be played in any audio CD player as a standard audio Compact Disc.



Getting Started

This User Guide provides instructions on how to record to CD with

CD Right! It contains a convenient, timesaving “Quick Guide” chapter.
For a more detailed explanation, please refer to the “How to...” topics in
the Online Help. If you are new to CD recording, we recommend that you
start from these “How to...” topics, browsing them on your computer.

The “Quick Command Reference” in this guide describes briefly the menu
structure. In the online Help you will also find a complete reference for each
command providing a detailed explanation for all the program menu functions.
The later Chapters are about special advanced functions. The last chapter,
“Errors and Troubleshooting”, will help you if a problem arises.



TO INSTALL

CD only

Please insert the Sony CD Right! disc in your drive and wait for the
“autostart” display. In this autostart window you can launch the CD Right!
installation. If the autostart is not active on your computer (¢.g. the Auto Insert
Notification is turned oft on the drive), look in My Computer for the icon of
the CD drive that says “SonyCDRight”. Double click on this icon to open, and
then double click on the “CDRight!Setup.exe” file to launch the installer.

On CD and On Floppy

1f you received both a CD and a floppy, please follow the instructions given
above, but remember to put the floppy in your A: drive before launching
the CD Right! installation. This way you ensure that the installation from the
CD will detect updated modules in the floppy and install the most recent ver-
sion.

TO UNINSTALL

Use the standard uninstall feature in Add/Remove Programs in the Control
Panel. When it is uninstalled, CD Right! does not leave anything behind in the
system.

If you want to know more about what the installation does and where the files
are, please consult the online Help.
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HOW TO TURN OFF/ON THE AUTO INSERT NOTIFICATION

The Auto Insert Notification is a feature of the Microsoft Operating Systems.
While it can be very helpful in some cases, it can also be very damaging for
the CD recording process.

You can use the Tools functions in CD Right! to turn off and on the Auto
Insert Notification. You will need to reboot your system to enable the change
to take effect.

Note: Having Auto Insert Notification turned off tends to make Windows
reluctant to refresh the contents information when a new disc is
mounted. You may need to press F5 a few times to force a full
refresh.

If you want to use the standard Windows interface to enable or disable Auto
Insert Notification, you can do that in Windows 95:

e Right-click on My Computer on the desktop.
e Select Properties from the menu

¢ Click on the Device Manager tab.



« Expand the CD-ROM icon {click the plus sign or double-click the icon) and
select the Drive you are interested in

» Click on the Properties button and then on the Settings tab of the
following dialog.

 Deselect or Re-select the Auto Insert Notification checkbox
e Click OK and then OK again, and you will be asked to reboot.

To learn more about Auto Insert Notification, see the Online Help.



Quick Guide

The following paragraphs offer step-by-step instruction on how to complete
quickly and successfully the key functions found in CD Right! Please follow
these steps by-the-number when in front of your computer with CD Right!
launched.

CD COorY .

To make a CD Copy means to physically duplicate a disc onto a blank record-
able one. To copy a CD, you need a good, clean, unscratched original and one
blank CD-R disc.

Note: The source disc could contain material that is protected by
Trademarks and Copyrights. Please, be sure you are authorized with
the right to replicate it.

You can copy from the CD-ROM you have in your systern or you can use the
same CD recorder as the source.

Copying From Another CD-ROM Drive:
1 Click on the CD Copy button of the main menu.

2 Insert the original in the CD-ROM, select the From field mode, then
insert the blank disc in the CD recorder.



Wait until both the CD-ROM and CD recorder become ready and indi-
cate, using the explanations in red, the correct disc descriptions.

Press the Record button (the red dot) in the toolbar.

In the following Record to CD dialog select the Speed and whether
you want to Test, Test and Record or Record.

Wait until the recording process completes.

Copying From the Same CD Recorder

1

2

Click on the CD Copy button of the main menu.

Insert the original in the CD recorder and select it in both the
Recorder and the From fields.

Wait until the CD recorder is ready. The description of the original
disc is indicated in red text.

Press the Record button (the red dot) in the toolbar.

In the following Record to CD dialog select the Speed and whether
you want to Test, Test and Record or Record.
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6 The original is read into the temporary folder and the CD recorder
ejects the original. Now you must insert the blank disc. At this point
there is no need to do anything further.

Note: If there is not enough space in the temporary folder, (the default is
the Windows temporary) and you have enough room on another hard
disk, you can change the CD Right! temporary location in the
Options under the Tools menu.

7 The blank disc is recognized, the recording process begins and all you
need do is wait until it is finished.



DATA CD-ROM

To make a Data CD-ROM means to copy tolders or files from your computer
onto a blank disc or partially written data disc. This disc, recorded in the 1SO-
9660 format, will be rcadable in any computer equipped with a CD-ROM
drive.

1 Click on the Data CD-ROM button of the main menu.

2 Define the folders or files you want to record, dragging and dropping
from the Window Shell of the Windows Explorer.

3 Give it a meaningful Volume Name because this name will be assigned
as the volume label of the CD-ROM.

4 Insert a blank CD-R disc in the recorder or a disc you have already
started as a Data CD-ROM and have left open and wait until the
recorder becomes ready. By then, the disc’s content and free space
appear in red under the Recorder combo box.

5 Select from loading the previous track (only if the disc is not blank) or
making a new volume in the free space and ignoring what the disc
already contains.

6 If you want to make a Mixed-mode disc (data and audio on the same
CD) or to exclude some files from recording or if you would like to
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make the CD bootable, please check the Advanced functions in the
online Help.

Press the Record button (the red dot) in the toolbar.

In the following Record to CD dialog, select the Speed and whether
you want to Test, Test and Record or go simply Record.

The recording process begins and all you need'do is wait until it is
finished.



AUDIO CD COMPILATION

To make an Audio Compilation means to select songs from other audio discs
or among some Wave files you prepared on your hard disk and then record
them onto a blank CD-R disc.

1 Click on the Audio CD Compilation button of the main menu.
2 Drop in the track (song) list of the Wave files, if you have any.

3 Drop or select, using the Add function in the Edit menu, the tracks
from other audio discs you want to include in the compilation.

Note: All the tracks you are using from other audio discs must be “on line”
at the beginning of recording. If your compilation is comprised from
more discs than the available CD-ROM drives you have, create Wave
files for some of them by “extracting” the audio to the hard drive.
You’ll learn more about this ahead in the Exploring Discs section.

4 Arrange the compilation sequence by right-clicking over the track and
selecting Move Up or Move Down.

5 Press the Record button (the red dot) in the toolbar.
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In the following Record to CD dialog select the Speed and whether
you want to Test, Test and Record or Record.

The recording process begins and all you need do is wait until it is
finished.



CD DITTO DJ

Making a disc with Ditto DJ means to create an “work in progress™ audio disc,
You start with a blank disc and record onc or more tracks at a time. The tracks
can be Wave files or tracks trom other audio discs. You can also record direct-
ly from your soundboard, with any audio source connected to the line-in jack.
The disc can be left “unfinished” and played in the CD recorder. When you
decide to “finish” the disc, it will then be playable in any audio CD player.

1 Click on the CD Ditto DJ button of the main menu.

2 Insert a blank CD-R disc in the recorder or a disc you have already
started with CD Ditto DJ.

3a If you want to record a song you have as a Wave file, drop this file in
the track list window or press the Recording button and select Wave
File.

Review the Record to CD dialog in which you can select only the recording
speed.

3b If you want to record a song directly from another audio disc, insert
this source disc in the CD-ROM and drop the Track file corresponding
to the song from there or press the Recording button and select Track
from Another CD.
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Review the Record to CD dialog in which you can select only the recording
speed.

3¢ If you want to record a track from any audio source, start your audio
board software or the standard Windows Recording Control and select
which input you want to record and its recording volume.

Note: You should do the same steps when recording a Wave file from that
source with your soundboard.

When you are ready to record, press the Recording button and select From
Mixer. Review the Record to CD dialog. In this situation you cannot select
anything because the live recording must be forced at 1x, which is “real time”.
When you decide to stop the live recording, just press the Stop button.

4 After recording one or more tracks, you can play the disc with the CD
Ditto DJ toolbar buttons or remove the disc from the drive.

5 Later you can add other tracks following the same previous steps, and,
when you decide that the disc is finished, press the Finish Disc button
to close it.



EXPLORING DISCS

To explore a disc means to look at the physical structure of a CD inserted in a
CD recorder or CD-ROM drive using the CD Explorer function of CD Right!
Explore Audio Discs and Extract Tracks (Songs)

1 Insert the disc to explore in a CD recorder or CD-ROM drive and
select CD Explorer from the CD-Drive menu entry corresponding to
that drive. Wait until the contents of the disc appear in the CD
Explorer window.

2 You can then verify all the tracks (songs) contained in the disc and
their details.

3 Select one or more tracks to extract by clicking on them.

4 Press the Extract as Wave File(s) button. Follow the dialog where the
name of the file(s) is requested and then confirm it.

Tip: You are also able to assign the Disc Author/Title and Songs Titles
from this CD Explorer window. This title will be visible in the
Windows CD Player and will help you identify discs and tracks while
preparing compilations.




Exploring Data Tracks

You can explore data tracks to access files and folders recorded in previous
tracks of muitisession data discs.

1 Insert the data disc to be explored in a CD recorder or CD-ROM drive
and select CD Explorer from the entry in the CD-Drive menu that
corresponds to the drive you are using. Wait until the contents of the
disc appear in the CD Explorer window.

2 Select only one file or track to explore.

3 Press the Explore Data Track Files button. In the following dialog
which works almost as any standard Open file Windows dialog, select
the folders or file to recover.

4 Enter the destination folder where to copy the files from the CD and
press the Extract button.



Quick Command Reference

FILE MENU

From the File Menu it 1s possible to make a Main Menu selection using the
New function or to Open and Save the document as in any Windows applica-
tion. This menu also contains the Record and Stop functions to start and stop
the recording phase.

EDIT MENU—DATA CD-ROM

When in Data CD-ROM, use the Edit Menu to prepare the recording list. With
the Paste and Add functions you can insert items in the list, and with Position
on CD, select the folder destination if it must be different from the default
(the same as in the source hard disk). Use the Move and Remove functions to
adjust the list. With the File Verify it is possible to check an already written
disc against the source item with a Windows File System level file-by-file
verification.

EDIT MENU—AUDIO COMPILATION

When in Audio Compilation, use the Edit Menu to prepare the recording track
list. With the Paste and Add functions you can insert tracks. Use the Move
and Remove functions adjusting and setting the list to the correct track order.
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EDIT MENU—DITTO DJ

When in Ditto DJ Audio, usc the Edit Menu to control the audio playback or
to Finish Disc.

CD-DRIVE MENU

This menu contains an entry for every CD-ROM or CD recorder drive present
in the computer. For every drive a submenu lets you select the CD Explorer
or other functions like Eject and Drive Properties.

VIEW MENU

The View Menu contains the options for the Status Bar or Toolbar in addi-
tion to the handy functions to Tile the CD Right! windows with the Explorer
for easier dragging and dropping of files (and Untile back).

TOOLS MENU

From the Tools Menu you can Launch some applications which are important
to CDRight! or to turn the Aute Insert Notification Off and On. You can start
the Wave Conversion or Wave Editor or build and record the Global-CD
Image. The last entry opens the Options dialog.

HELP MENU

The Help Menu is quite standard for a Windows application and contains a
direct link to a few Internet Web sites of interest to CD Right! users.
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Options

The user options in CD Right! have been simplitied as much as possible. You
access the Options dialog from the Tools menu or from the Record to CD
dialog that appears just before recording. The Options dialog is divided into
three “Tabs™.

GENERAL
Eject the caddy or open the tray when the recording terminates

When you select this option, the tray or the caddy is ejected at the completion
of the recording session. You can verify in the Drive Properties if Eject/Close
is needed after a test. (Please note this option differs from the eject which is
performed automatically after running the Test and Record option).

Play sounds

CD Right! plays an audio sound when the recording or the test terminates or
when an error occurs. The sound is made as a reminder for the user that inter-
vention is now required. This option allows you to turn On or Off the sounds.

Use the slowest speed to extract audio which assists in improving
quality

Audio extraction occurs when you are copying a disc that contains audio
tracks such as a common audio CD or a Mixed-mode disc and when you

2



extract tracks from the CD Explorer. By default the extraction occurs at the
maximum speed to minimize the risks of Buffer Underrun (when copying) or
while waiting (when extracting from the CD Explorer). Extracting tracks at a
fast speed can generate additional sound noises like little “pops™ or “scratch-
es” with some drives. Therefore we recommend forcing the unit to extract at a
slower speed. This is usually close to 1x, where every second of music will
require | second to be extracted.

You can test the quality of the extraction after havfng this option checked or
unchecked in the Diagnostic tab, located under the CD Drives pull down
menu, in Drive Properties option.

Note: If you decide to use this option, please remember that you will not
be able to copy the audio disc directly from another unit. You must
choose to pass the tracks through to the Temporary file on the hard
disk.

Temporary Folder

Temporary space is needed when copying a disc and checking this option to
pass files through to the hard disk and when you record Data CD-ROM. You
select here where you want CD Right! to copy the temporary files. By default
this folder is the Windows temporary but you can move it to any other hard
disk attached to your computer. This default can be restored using the Default
button.
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DATA CD SWAP

In this scction of the Options dialog you set a threshold for the Data CD-ROM
recording. When you record data from your hard disk to the CD, all the files,
the CD file system and all the other information are built and copied “on the
fly™. If the hard disk is not very fast or if the number of files is very large, the
time needed to reach the files could be too high to record at 4x or even 2x
speed. CD Right! copies all the files smaller than the threshold size you sefect
here into a temporary file in the Temporary Folder before actually recording.
When the moment of recording these files arrives, instead of going back and
forth on the hard disk to find them, the files are already located in this “swap”
file in the order as they are needed. CD Right! saves in “open and seek time”
as the experts say.

The.swap file is always deleted when the recording terminates.



MULTISESSION

There are three options to resolve a “collision” when you are about to record a
file(s) to disc and you have selected loading a previous session and this file(s)
exists already in the loaded session.

Never Overwrite

If a file(s) is already present in the loaded session, the new file(s) is not
recorded. ‘

The only file(s) recorded is that not present in the loaded session.

Overwrite If Newer

The file(s) that is newer is recorded. The one(s) that has the same date and
time as in the loaded session is only referenced back, saving disc space.

Always overwrite

All the files selected for recording are written regardless of their date and
time. Only the one(s) that was present in the loaded session and now is not
selected for recording again is “pointed back”.

If you do not have a clear picture of how the multisession works, please see
the online Help.



Errors and Troubleshooting

CD Right! reports all errors in a dialog that indicates which drive generated
the problem, gives a brief explanation, and specifies (in red) the Error Code
in the format EE-CC-SSAAQQ-RR.

* EE is the CD Right! error code, that corresponds to the given message.

¢ CC is the last command sent to the drive that generated or let the error
happen.

* SS 1s the drive SCSI/ATAPI error Sense code.
® AA is the drive SCSI/ATAPI error Additional Sense code.
* QQ is the drive SCSI/ATAP! error Additional Sense code Qualifier.

* RR is a redundant code generated by the previous S values. It is created to
verify that the entire code is reported correctly.

The fields CC, SS, AA and QQ are very often specific to the drive where the
error happens and will be interpreted by technical support when needed.

Reporting an Error to Technical Support

If one of these error occurs and you need technical support for help or for an
explanation, please write down the entire Error Code written in red with the
name of the drive that generated the error and have this information ready
when asked.
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ERROR EXPLANATIONS

Listed are all the possible Error codes with an explanation and a possible
correction:

WinASPl is not installed or is not working on this computer.
We cannot continue.

WinASPILi.WinASPI; (the module used to communicate with your
SCSLi.SCSI; peripherals) is not installéd or is not working on this comput-
er. WinASPI is necessary for CD Right! to work. You must install it correct-
ly before CD Right! can start.

Solution: Install the Windows ASPI 32 interface.

The file: <filename> cannot be read. Please check if it has been deleted
or if it is read protected. '

A file that was found and listed while preparing an 1S0-9660.i.1SO-9660;
image is not found during the recording process. This could happen if
somebody deletes the file while writing or opens the file so it is no longer
available for reading.

Solution:  Verify that <filename> exists or close the application that is
holding its shareability.
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The file: <filename> is corrupted or unknown.

A file such as a Wave tile used in a compilation or a Global-CD Image that
you are trying to record is damaged or in a wrong format.

Solution:  Verify that <filename> is in the supposedly correct format.

Error while reading the source disc.

Physical error reading a track from a drive. This can happen during copying
or extracting tracks from a CD to the hard drive.

Solution:  Verify that the source disc is not damaged. Try cleaning the
disc and removing the dust from the environment. Verify that
the source CD is in good condition.

Drive error. <cause>

The SCSLi.SCSI; (or SCSI'ized) specified drive reported a physical "unit
error". The <cause> indicates the reason but you should refer to the drive
manufacturer command manual for the meaning of the Sense code,
Additional sense code and Additional sense code qualifier.

Solution: There are several reasons for a Drive Error. Verify the connec-
tion of the drive and run the Record Basic Functions located
in the Diagnostic tab, located under the CD Drives pull down
menu, in Drive Properties option.
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The disc is bad or its type is incompatible with the selected speed or
the CD recorder requirements.

In some CD recorders there is a special command to check the validity of
the disc onto which you are recording. This check s performed by CD
Right! just before the recording process begins. This error occurs if the
drive returns a message that the disc is not valid or compatible with the
selected speed.

Solution: Use a lower speed or use a different disc brand.

Error in the communication with the drive.

The SCSI; or the IDE/ATAPI interface reported a problem while communi-
cating with the device.

Solution: Do not touch or access the drive using another application
while reading or recording. Verify that the Auto Insert
Notification is turned Off. Verify the connection of the drive
and run the Record Basic Functions located in the Diagneostic
tab, located under the CD Drives pull down menu, in Drive
Properties option to detect if there is any hardware problem.



Not enough memory to complete the operation.

Due to an extremely high number of files in the image and/or a very low
amount of memory in the system, CD Right! is not able to prepare the Data
CD file structure.

Solution: Try to close the other applications running, restart the machine
or add additional memory in the system which is required to
master complicated discs. ~ :

The temporary folder does not have enough free space for the swap
file.

During the preparation of a Data CD, the swap file becomes too large for

the Temporary Folder.

Solution: Make room for the Temporary Folder or reduce the threshold
value in the Data CD Swap section of the Options.

Error completing the operation or function not supported by the
recorder.

This message indicates you are trying to perform an operation not support-

ed by your CD recorder or an unexpected error happened.

Solution:  Verify that the Auto Insert Notification is turned Off. Verify the
connection of the drive. Call for technical support assistance if
problem persists.
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